Link to the correct Ruby shared object.
[ruby-evas.git] / src / Makefile.am
index 3ef9ce7c6c785aedc88c469782d1647c39b0ffc8..860f5b83aca5248511a71801aed8be4f51edb3cb 100644 (file)
@@ -1,4 +1,4 @@
-## $Id: Makefile.am 23 2004-06-26 22:55:31Z tilman $
+## $Id: Makefile.am 118 2004-10-18 20:16:11Z tilman $
 
 AM_CFLAGS = $(EVAS_CFLAGS)
 INCLUDES = -I$(RUBYDIR)
@@ -14,10 +14,11 @@ evas_la_SOURCES = rb_evas_main.c rb_evas_main.h \
                   rb_gradient.c rb_gradient.h \
                   rb_polygon.c rb_polygon.h \
                   rb_image.c rb_image.h \
-                  rb_text.c rb_text.h
+                  rb_text.c rb_text.h \
+                  rb_smart.c rb_smart.h
 
-evas_la_LIBADD = -lruby $(EVAS_LIBS)
+evas_la_LIBADD = -L$(RUBYLIBDIR) $(RUBYLIB) $(EVAS_LIBS)
 evas_la_LDFLAGS = -module -avoid-version
 
-pkgincludedir = $(RUBYSITEDIR)
+pkgincludedir = $(RUBYSITEDIR)/evas
 pkginclude_HEADERS = rb_evas_object.h rb_evas.h