Added more Evas objects.
[ruby-evas.git] / src / Makefile.am
index 5f269383250c1363260ad7c2626e2e0e86c05a05..3ef9ce7c6c785aedc88c469782d1647c39b0ffc8 100644 (file)
@@ -1,4 +1,4 @@
-## $Id: Makefile.am 2 2004-06-19 18:55:39Z tilman $
+## $Id: Makefile.am 23 2004-06-26 22:55:31Z tilman $
 
 AM_CFLAGS = $(EVAS_CFLAGS)
 INCLUDES = -I$(RUBYDIR)
@@ -6,11 +6,18 @@ INCLUDES = -I$(RUBYDIR)
 ext_LTLIBRARIES = evas.la
 extdir = $(RUBYSITEDIR)
 
-evas_la_SOURCES = rb_evas.c rb_evas.h \
-                  rb_evas_object.c rb_evas_object.h
+evas_la_SOURCES = rb_evas_main.c rb_evas_main.h \
+                  rb_evas.c rb_evas.h \
+                  rb_evas_object.c rb_evas_object.h \
+                  rb_rectangle.c rb_rectangle.h \
+                  rb_line.c rb_line.h \
+                  rb_gradient.c rb_gradient.h \
+                  rb_polygon.c rb_polygon.h \
+                  rb_image.c rb_image.h \
+                  rb_text.c rb_text.h
 
 evas_la_LIBADD = -lruby $(EVAS_LIBS)
 evas_la_LDFLAGS = -module -avoid-version
 
 pkgincludedir = $(RUBYSITEDIR)
-pkginclude_HEADERS = rb_evas_object.h
+pkginclude_HEADERS = rb_evas_object.h rb_evas.h