Link to the correct Ruby shared object.
[ruby-esmart.git] / src / esmart_trans_x11 / Makefile.am
index 6c097cc8438483fd00d6ec3bed216a111ca73dda..a615abfa2c154261ec32626c51e4e3b05b1a3442 100644 (file)
@@ -1,4 +1,4 @@
-## $Id$
+## $Id: Makefile.am 121 2004-10-18 20:24:05Z tilman $
 
 AM_CFLAGS = $(ESMART_CFLAGS)
 INCLUDES = -I$(RUBYDIR) -I$(RUBYSITEDIR)
@@ -8,5 +8,6 @@ extdir = $(RUBYSITEDIR)
 
 esmart_trans_x11_la_SOURCES = rb_esmart_trans_x11.c
 
-esmart_trans_x11_la_LIBADD = -lruby $(ESMART_LIBS) -lesmart_trans_x11
+esmart_trans_x11_la_LIBADD = -L$(RUBYLIBDIR) $(RUBYLIB) $(ESMART_LIBS) \
+                             -lesmart_trans_x11
 esmart_trans_x11_la_LDFLAGS = -module -avoid-version