Link to the correct Ruby shared object.
[ruby-esmart.git] / src / esmart_container / Makefile.am
index cdec71afffd69c80d2161f522428b0d9d8349c86..87a61a3d76d78cd1bc90c15880b2f8eeb4785285 100644 (file)
@@ -1,4 +1,4 @@
-## $Id: Makefile.am 75 2004-08-16 18:17:19Z tilman $
+## $Id: Makefile.am 121 2004-10-18 20:24:05Z tilman $
 
 AM_CFLAGS = $(ESMART_CFLAGS)
 INCLUDES = -I$(RUBYDIR) -I$(RUBYSITEDIR)
@@ -8,6 +8,6 @@ extdir = $(RUBYSITEDIR)
 
 esmart_container_la_SOURCES = rb_esmart_container.c
 
-esmart_container_la_LIBADD = -L$(RUBYLIBDIR) -lruby $(ESMART_LIBS) \
+esmart_container_la_LIBADD = -L$(RUBYLIBDIR) $(RUBYLIB) $(ESMART_LIBS) \
                              -lesmart_container
 esmart_container_la_LDFLAGS = -module -avoid-version