Makefiles for both OpenSSL and PolarSSL support
[umurmur.git] / openwrt / Makefile.openssl
diff --git a/openwrt/Makefile.openssl b/openwrt/Makefile.openssl
new file mode 100644 (file)
index 0000000..f989ee7
--- /dev/null
@@ -0,0 +1,52 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=umurmur-openssl
+PKG_VERSION:=0.2.0
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+
+define Package/umurmur-openssl
+       SECTION:=net
+       CATEGORY:=Network
+       TITLE:=uMurmur
+       DEPENDS:=+libopenssl +libconfig
+       URL:=http://code.google.com/p/umurmur
+       MAINTAINER:=Martin Johansson <martin@fatbob.nu>
+endef
+
+define Package/umurmur-openssl/description
+       Minimalistic Mumble server daemon.
+       Uses OpenSSL library for SSL and crypto.
+endef
+
+TARGET_CFLAGS := \
+        -DWRT_TARGET \
+        $(TARGET_CFLAGS)
+
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/CompileTarget
+       CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)"\
+       $(MAKE) -C $(PKG_BUILD_DIR)/umurmur.$(1)/umurmur \
+               all
+endef
+
+define Package/umurmur-openssl/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/umurmurd $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/umurmur.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/umurmur.init $(1)/etc/init.d/umurmur
+       $(INSTALL_DIR) $(1)/etc/umurmur
+endef
+
+$(eval $(call BuildPackage,umurmur-openssl))
+