Create the callbacks hash on first use.
[ruby-ecore.git] / src / ecore_x / Makefile.am
index ae04a7a75ff52afd8a5d18cea4fad72f3f723eff..71b5eec7acc9f9a2bda740dd96c69e6e2ba56e71 100644 (file)
@@ -1,4 +1,4 @@
-## $Id: Makefile.am 72 2004-08-16 18:10:27Z tilman $
+## $Id: Makefile.am 120 2004-10-18 20:23:32Z tilman $
 
 AM_CFLAGS = $(ECORE_CFLAGS)
 INCLUDES = -I$(RUBYDIR) -I$(RUBYSITEDIR)
@@ -7,9 +7,10 @@ ext_LTLIBRARIES = ecore_x.la
 extdir = $(RUBYSITEDIR)
 
 ecore_x_la_SOURCES = rb_ecore_x.c rb_ecore_x.h \
-                     rb_window.c rb_window.h
+                     rb_window.c rb_window.h \
+                     rb_cursor.c rb_cursor.h
 
-ecore_x_la_LIBADD = -L$(RUBYLIBDIR) -lruby $(ECORE_LIBS)
+ecore_x_la_LIBADD = -L$(RUBYLIBDIR) $(RUBYLIB) $(ECORE_LIBS)
 ecore_x_la_LDFLAGS = -module -avoid-version
 
 pkgincludedir = $(RUBYSITEDIR)/ecore