Link to the correct Ruby shared object.
[ruby-ecore.git] / src / ecore_x / Makefile.am
index 064506df2f17e0787ad09bf5b369c6edf365fb50..71b5eec7acc9f9a2bda740dd96c69e6e2ba56e71 100644 (file)
@@ -1,4 +1,4 @@
-## $Id: Makefile.am 98 2004-08-26 13:12:55Z tilman $
+## $Id: Makefile.am 120 2004-10-18 20:23:32Z tilman $
 
 AM_CFLAGS = $(ECORE_CFLAGS)
 INCLUDES = -I$(RUBYDIR) -I$(RUBYSITEDIR)
@@ -10,7 +10,7 @@ ecore_x_la_SOURCES = rb_ecore_x.c rb_ecore_x.h \
                      rb_window.c rb_window.h \
                      rb_cursor.c rb_cursor.h
 
-ecore_x_la_LIBADD = -L$(RUBYLIBDIR) -lruby $(ECORE_LIBS)
+ecore_x_la_LIBADD = -L$(RUBYLIBDIR) $(RUBYLIB) $(ECORE_LIBS)
 ecore_x_la_LDFLAGS = -module -avoid-version
 
 pkgincludedir = $(RUBYSITEDIR)/ecore