Create the callbacks hash on first use.
[ruby-ecore.git] / src / ecore / Makefile.am
index f3c8a0869b12c6d62ce42292faea6d3e859c6c18..2f745845e4cfd207f8da266ac7b955464192aed2 100644 (file)
@@ -1,4 +1,4 @@
-## $Id: Makefile.am 77 2004-08-19 17:39:29Z tilman $
+## $Id: Makefile.am 152 2004-12-09 18:33:15Z tilman $
 
 AM_CFLAGS = $(ECORE_CFLAGS)
 INCLUDES = -I$(RUBYDIR)
@@ -8,8 +8,11 @@ extdir = $(RUBYSITEDIR)
 
 ecore_la_SOURCES = rb_ecore.c rb_ecore.h \
                    rb_idler.c rb_idler.h \
+                   rb_idle_enterer.c rb_idle_enterer.h \
                    rb_timer.c rb_timer.h \
-                   rb_event_handler.c rb_event_handler.h
+                   rb_animator.c rb_animator.h \
+                   rb_event_handler.c rb_event_handler.h \
+                   rb_fd_handler.c rb_fd_handler.h
 
-ecore_la_LIBADD = -L$(RUBYLIBDIR) -lruby $(ECORE_LIBS)
+ecore_la_LIBADD = -L$(RUBYLIBDIR) $(RUBYLIB) $(ECORE_LIBS)
 ecore_la_LDFLAGS = -module -avoid-version